+ Responder ao Tópico
Resultados 1 a 8 de 8
  • Compartilhar Post
  • Ferramentas de Tópicos
  1. #1
    Data de Ingresso
    Apr 2008
    Posts
    2.656

    Certificado Digital X IE10 - não instala o certificado!

    Pessoal, alguem poderia dar uma dica:

    Tenho na empresa um pc que precisa rodar um programa emissor de CT-e e NF-e que utiliza certificado digital da empresa (e-cnpj em formato de smartcard), ocorre que o programa nao esta conseguindo enviar os dados para a receita federal porque não consigo fazer com que o certificado digital da empresa seja instalado pelo internet explores na aba "Pessoal" do item "certificados", pois o certificado fica na aba "outros" e o programa não consegue utilizar a certificação digital desta forma. Consegui instalar ele corretamente no Firefox, mas o programa não trabalha com o firefox e por isso continua nao funcionando.
    Alguem tem alguma dica sobre como forçar o certificado digital modelo A3 (e-cnpj em smartcard) ficar na aba "Pessoal" do iten "Certificados" dentro do Internet Explorer?

    Estou usando o Win7 x64 nesse PC, o mesmo está com SP1 instalado e o IE é a versão 10 (era a ver 8, mas o pessoal do suporte da Certisign que emitiu o certificado para a empresa recomendou instalar a vers. 10 e todos os componentes Java atuais, mesmo ssim nao funciona como deveria)

    Não sei o que fazer mais...e o programa está la parado sem emitir os dados para a Receita...o pessoal do suporte do software joga a batata quente para o pessoal da Certisign e vice-versa, e o cliente (eu) fica que nem idiota no meio dessa falta de profissionalismo total de ambas as empresa, a BSoft e a Certisign, estou em injuriando com essa porra e vou acabar processando ambas no PROCON!
    i7 2600K - Tt Frio - MSI Z68A GD65 G3 - SSD 128GB // 8GB DDR3 1600 GSkill ECO 7-8-7-24 1.35v - MSI GTX 670 P.E - TT TouchPower XT 875W - BluRay Recorder - AeroCool PGS-B BX 500
    [/FONT]



  2. #2
    Data de Ingresso
    Oct 2012
    Localização
    BH/MG
    Posts
    2.370
    o certificado entra normalmente no ecac usando o ie10?
    se estiver entrando o problema tem que ser resolvido pela empresa do software da nota fiscal, já que o cartão esta funcionando no principal portal da rf.
    ------------
    a esqueci de perguntar tb, o programa mostra algum erro na hora de assinar a nota com o certificado?
    Se ajudei, qualifique

  3. #3
    Cara desinstala o ie 10 e volta para o 8 ou 9. É a melhor solução, o ie10 ta bugado aqui tbm, não funciona mais os bancos (bb, caixa)....
    | XBOX 360 Slim | Macbook Pro |



    | ASUS MAXIMUS IV GENE | i7 4770k | 4X4GB Kingston Blue 1600 Mhz | SSD Kingston Hyper 240GB | VGA Sapphire HD 7970 | Cooler Master N200 |

  4. #4
    Data de Ingresso
    Apr 2008
    Posts
    2.656
    Citação Postado originalmente por dudu1505 Ver Post
    o certificado entra normalmente no ecac usando o ie10?
    se estiver entrando o problema tem que ser resolvido pela empresa do software da nota fiscal, já que o cartão esta funcionando no principal portal da rf.
    ------------
    a esqueci de perguntar tb, o programa mostra algum erro na hora de assinar a nota com o certificado?
    Entao, o ie nao abre o e-cac, so o firefox onde o certificado aparece no local correto, antes eu estava com o instalado e o problema ja ocorria, coloquei o 10 e continuou tb...vou formatar o PC e fazer uma nova instalacao do win7 e tentar novamente para acabar com as opcoes do pessoal do suporte, se nao funcionar eu nao sei o que farei, pq ta um empurra empurra desgracado isso....
    O erro que o programa mostra é tipico de erro de sistema "Object not found" com o simbolo de parada critica do windows na msgbox em que aparece o erro. O pessoal do suporte do software diz que ele so reconhece o certificado se estiver instalado no IE e deve aparecer na aba "Pessoal".
    Citação Postado originalmente por Rickrs Ver Post
    Cara desinstala o ie 10 e volta para o 8 ou 9. É a melhor solução, o ie10 ta bugado aqui tbm, não funciona mais os bancos (bb, caixa)....
    vou ver isso...vou formatar o pc e instalar tdo novamente, quero so ver...se esse lixo nao funcionar eu paro tdo e suspendo a implantacao do software, porque nao e possivel vc pagar 1.500 num programa e nao conseguir fazer ele funcionar, e ainda nao obter um suporte adequado!
    i7 2600K - Tt Frio - MSI Z68A GD65 G3 - SSD 128GB // 8GB DDR3 1600 GSkill ECO 7-8-7-24 1.35v - MSI GTX 670 P.E - TT TouchPower XT 875W - BluRay Recorder - AeroCool PGS-B BX 500
    [/FONT]

  5. #5
    Não precisa formatar, dá para desinstalar somente o IE.
    | XBOX 360 Slim | Macbook Pro |



    | ASUS MAXIMUS IV GENE | i7 4770k | 4X4GB Kingston Blue 1600 Mhz | SSD Kingston Hyper 240GB | VGA Sapphire HD 7970 | Cooler Master N200 |

  6. #6
    Data de Ingresso
    Jun 2008
    Localização
    Minas Gerais - Belo Horizonte
    Posts
    2.655
    qual erro dá quando vc tenta instalar o certificado ? dependendo, é facil de se resolver!
    Só sei que nada sei!

  7. #7
    Data de Ingresso
    Apr 2008
    Posts
    2.656
    Citação Postado originalmente por Rickrs Ver Post
    Não precisa formatar, dá para desinstalar somente o IE.
    Vou tentar tirar o IE primeiro e por o 9...vms ver!

    Citação Postado originalmente por By_Zaca Ver Post
    qual erro dá quando vc tenta instalar o certificado ? dependendo, é facil de se resolver!
    Entao nao da erro na instalacao do certificado, eu consigo instalar ele pelo metodo mais comum que clicando duas vezes sobre ele e o win7 faz o resto importando para o sistema o certificado, ele ate pergunta onde quero por o certificado e eu escolho "Pessoal" para aparecer em tal local do IE, ele importa e informa sucesso na operacao, mas qdo abro o IE o certificado aparece na aba "outros" e não funciona, nao e reconhecido ao acessar o e-cac por exemplo. O programa que implantei la tb usa o msmo certificado para comunicar com a receita, qdo eu tento enviar os CT-e o programa informa "Error - Object not found" com icone de parada critica do windows. O pessoal do suporte diz que o programa tenta procurar o certificado pelo IE e nao pelo Mozilla, e por isso nao adianta ter o certificado instalado no mozila!

    O que eu preciso:
    Que o certificado seja importado pelo IE e que ele fique na aba "pessoal", assim o software consegue ler o registro e encontrar o certificado e assim acionar-lo para conexao direta com a Receita Federal!
    i7 2600K - Tt Frio - MSI Z68A GD65 G3 - SSD 128GB // 8GB DDR3 1600 GSkill ECO 7-8-7-24 1.35v - MSI GTX 670 P.E - TT TouchPower XT 875W - BluRay Recorder - AeroCool PGS-B BX 500
    [/FONT]

  8. #8
    Data de Ingresso
    Apr 2008
    Posts
    2.656
    Realmente nao tem jeito, re-instalei o ie9 e o problema persiste...o certificado alias continua no mesmo lugar e nao pode ser excluido...vou formatar e qdo estiver com o sistema instalado, vou direto ao suporte da Certisign para pedir auxilio na instalacao do certificado, quero so ver qual sera a desculpa se nao funcionar....
    ------------
    Consegui habilitar o certificado digital cnpj da Certisign no IE, porém tive de formatar o disco e re-instalar o win7 e manter o IE 8 original.
    Assim que instalei tudo no PC, liguei para a Certisign e dei uma de novato e afirmei ao atendente "estou com um PC novo, preciso habilitar o certificado digital no IE para usar com software de terceiros comunicação com a R.F."....seguimos alguns passos, tivemos de baixar 2 utilitarios, um que é um tipo de fix do registro e o outro é o utilitário da Certisign, chamado safesign, ele que gerencia o cartão criptográfico!
    Após todo procedimento, fomos direto ao site da receita e acessamos o portal e-cac, de cara o IE exibiu o certificado e eu escolhi ele, pediu a senha pin, digitei e pronto...to dentro!
    Fui verificar no IE o local do certificado, e agora sim ele aparece na aba "Pessoal", portanto está corretamente habilitado, não tem mais espaço para o pessoal do software emissor de CT-e dizer que a culpa é do IE ou do certificado digital, a Certisign fez a parte dela, agora vou para etapa seguinte, que é instalar o programa da transportadora e tentar enviar os CT-e...será a hora da verdade logo mais!

    Obs:
    O PC nao pode em hipotese alguma usar outro IE, principalmente o 10, nem add-ons e essas tranqueiras que estao vagando pela internet e que sempre os noobs acabam por instalar no PC, senão é pau na hora...portanto vou inutilizar o PC para outras tarefas e deixar ele somente para rodar o controle de transportadoras c/ emissor de CT-e, pois é o tipo da coisa que não pode ninguerm ficar acessando a internet, facebook, sites de joguinhos...etc, portanto la vms nós montar outro PC para ficar no lugar desse que agora ficou exclusivo para comunicação com a R.F!
    Qta grana se gasta por causa de coisas que deveriam ser simples...

    Volto com o resultado final dessa aventura maluca que me consumiu uma semana até agora!
    i7 2600K - Tt Frio - MSI Z68A GD65 G3 - SSD 128GB // 8GB DDR3 1600 GSkill ECO 7-8-7-24 1.35v - MSI GTX 670 P.E - TT TouchPower XT 875W - BluRay Recorder - AeroCool PGS-B BX 500
    [/FONT]



Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  • BB Code está Ligado
  • Smilies estão Ligados
  • Código [IMG] está Ligado
  • Código HTML está Desligado



  
ANÁLISES Ver lista completa VIDEOS Ver lista completa NOTÍCIAS Ver lista completa COLUNAS
redacao 
carlos 
thiago 
carlos 
redacao 
Ver lista completa

CANAIS: TECNOLOGIA | TELECOM | INTERNET | SEGURANÇA | GAMES |

SEÇÕES: NOTÍCIAS | REVIEWS | ENTREVISTAS | COLUNISTAS | COBERTURAS | DOWNLOADS | VÍDEOS | PODCAST | ENQUETES | BIBLIOTECA | PROMOÇÕES | FÓRUM | RSS

A EMPRESA | EQUIPE | PARCEIROS | PUBLICIDADE | FALE CONOSCO | CONDIÇÕES DE USO | POLÍTICA DE PRIVACIDADE

COPYRIGHT © 2001 - 2013 ADRENALINE.COM.BR. TODOS OS DIREITOS RESERVADOS. ADRENALINE É UMA MARCA REGISTRADA DA ADRENALINE FRANQUIAS.